Community College of Rhode Island

Go to 50th Anniversary website

Get Adobe Reader

*PDF files require Adobe Acrobat Reader to view - Download here

Important Note:

Previous releases of MyCCRI [and Pipeline] would warn users about unsupported browsers. As part of the new MyCCRI feature set, browser checking is now turned off by default. While the browsers listed in the chart are those that are certified for use with the current version of MyCCRI, the system will not enforce these requirements.

Browsers that work with MyCCRI

Internet Explorer

Internet Explorer 8 for Windows is the only fully supported browser at CCRI

Selected other browsers, on which CCRI provides limited support, will allow you to log in to MyCCRI and use the system effectively. If you prefer to use one of the other browsers mentioned below, click on its link to download (many older versions are no longer available --see footnote below).

Operating
System
Browser Browser Version Will work
with MyCCRI
CCRI fully
Supported
Windows Internet
Explorer
9.0 Yes No
Windows Internet
Explorer
8.x Yes Yes
Windows Firefox 3.5*, 3.6 and 4.0 Yes No
Macintosh Firefox 3.x and 4.0 Yes No
Macintosh Safari 3.x, 4.x and 5.05 Yes No

*Older version no longer available on browser's official website - CCRI does not recommend downloading from unauthorized sites.

This page developed and maintained by Information Technology. Send comments and suggestions to .


Last Updated: 7/24/13