Banner 7.x
Student Overview

Community College of Rhode Island
October 2006
Version 2.0
# Table of Screen Shots

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Loading screen</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>Banner General Menu</td>
<td>4</td>
</tr>
<tr>
<td>3</td>
<td>Forms Open</td>
<td>5</td>
</tr>
<tr>
<td>4</td>
<td>General Menu: Go To...</td>
<td>5</td>
</tr>
<tr>
<td>5</td>
<td>Hierarchical Menu Structure</td>
<td>6</td>
</tr>
<tr>
<td>6</td>
<td>Direct Access: Go To… bar</td>
<td>6</td>
</tr>
<tr>
<td>7</td>
<td>Options Menu</td>
<td>7</td>
</tr>
<tr>
<td>8</td>
<td>Query Pull-Down Menu</td>
<td>8</td>
</tr>
<tr>
<td>9</td>
<td>Query Toolbar Icons</td>
<td>8</td>
</tr>
<tr>
<td>10</td>
<td>SOAIDEN Initial Search Criteria</td>
<td>9</td>
</tr>
<tr>
<td>11</td>
<td>Query Results</td>
<td>9</td>
</tr>
<tr>
<td>12</td>
<td>SOAIDNS</td>
<td>10</td>
</tr>
<tr>
<td>13</td>
<td>Query Results</td>
<td>10</td>
</tr>
<tr>
<td>14</td>
<td>GUASYST</td>
<td>11</td>
</tr>
<tr>
<td>15</td>
<td>SSASECQ</td>
<td>11</td>
</tr>
<tr>
<td>16</td>
<td>SSASECQ Match</td>
<td>12</td>
</tr>
<tr>
<td>17</td>
<td>SPAIDEN</td>
<td>12</td>
</tr>
<tr>
<td>18</td>
<td>SOAHOLO</td>
<td>13</td>
</tr>
<tr>
<td>19</td>
<td>Pipeline View</td>
<td>13</td>
</tr>
<tr>
<td>20</td>
<td>SGASTDN Learner</td>
<td>14</td>
</tr>
<tr>
<td>21</td>
<td>SGASTDN Curricula</td>
<td>14</td>
</tr>
<tr>
<td>22</td>
<td>SGASTDN Field of Study</td>
<td>14</td>
</tr>
<tr>
<td>23</td>
<td>SGASTDQ</td>
<td>15</td>
</tr>
<tr>
<td>24</td>
<td>SASSECT</td>
<td>15</td>
</tr>
<tr>
<td>25</td>
<td>SSASECT Meeting Time</td>
<td>16</td>
</tr>
<tr>
<td>26</td>
<td>SFAREGQ</td>
<td>16</td>
</tr>
<tr>
<td>27</td>
<td>Online Help</td>
<td>25</td>
</tr>
<tr>
<td>28</td>
<td>Pull down menu</td>
<td>25</td>
</tr>
<tr>
<td>29</td>
<td>Online Help icon</td>
<td>25</td>
</tr>
<tr>
<td>30</td>
<td>General Menu Help Center</td>
<td>25</td>
</tr>
</tbody>
</table>
1 Banner Basics

Banner is a web-based application accessed with an Internet browser. The CCRI Information Technology department supports Internet Explorer, Microsoft’s browser. A browser plug-in will install, with some user interaction, the first time Banner is started on a computer. (See Appendix E)

Once the proper software is installed, clicking the Banner Login button will bring up an initiation screen which must remain open the entire Banner session. (See Figure 1) This window can be minimized without interfering with the session. Banner loads and runs in a separate window. (See Figure 2)

Banner is a collection of screens or forms organized into functional areas or products. The Banner products CCRI uses are Student, Financial Aid, Finance, Human Resources and General. Modules are organized within each product with the actual forms built around the functions of the module. Some of the modules found in the Student product are; Course Catalog, General Person, Faculty Load, Admissions, Registration and Academic History. The job function of the user determines which products, modules, and forms he or she can see and access.

Figure 1 - Loading screen

Figure 2 - Banner General Menu
2 Forms

A form is a grouping of information organized into sections or blocks for easier viewing. Like a paper form that has multiple pages, a form may consist of multiple screens. There is more than one kind of form and each type may have different functions and ways of displaying information.

2.1 Types of Forms

- Inquiry – Used to look up existing data.
- Application – Most common type of form. Provides data entry and query capabilities.
- Query – Used to look up existing data. Can only be accessed from another form. Usually shows multiple records in a list format.

2.2 Accessing Forms

Banner allows multiple forms to be open at once. Generally, the best practice is to close a form before opening another form, especially when entering data. The open forms are displayed along the top of the Banner window. (See Figure 3)

![Figure 3 - Forms Open](image)

2.2.1 ‘Go To’ box

At the Banner General Menu screen, type the 7-character form name directly into the ‘Go To’ box. Press Enter on the keyboard to open the form. (See Figure 4)

![Figure 4 - General Menu: Go To…](image)

2.2.2 Navigating the Hierarchical Tree Menu Structure

Find the desired product, i.e. Student or Financial, double-click to expand the menu, continue double-clicking until the needed form name is displayed. Double-click the form name or press enter on the keyboard. (See Figure 5)
2.2.3 Direct Access

From the menu bar, select File ➔ Direct Access, a ‘Go To’ bar will open at the top of the current form. *(See Figure 6)* Type the name of the form in the box, press Enter on keyboard. To close ‘Go To’ bar, select File ➔ Direct Access again.

Using Direct Access to open a form will leave the current form open.

2.2.4 Options Menu

The Options menu is a way of navigating to different blocks of the current form or opening related forms. Each form and possibly each block may have different destinations listed on the Options menu; some may have no options listed. Click Options then click the desired form or block. *(See Figure 7)*

Using Direct Access to open a form will leave the current form open.
2.3 Form Elements and Navigation

<table>
<thead>
<tr>
<th>Definition</th>
<th>Pull-Down Menu and Toolbar Icons</th>
<th>Keyboard Navigation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
<td>Labeled space, check-box, radio-button, or text box on a form. Used to display, enter, or query for information.</td>
<td>![Image of pull-down menu and toolbar icons]</td>
</tr>
<tr>
<td>Record</td>
<td>Groups of fields comprising a logical unit. Some forms display more than one record at a time; use the horizontal scroll bar to view all records.</td>
<td>![Image of keyboard navigation icons]</td>
</tr>
<tr>
<td>Block</td>
<td>Chunks of information grouped together. <strong>Key Block - Contains information that determines what is entered or displayed on the remainder of the form.</strong></td>
<td>![Image of keyboard navigation icons]</td>
</tr>
</tbody>
</table>

3 Searching

Many form fields will only accept specific values or codes. The search icon ![Search Icon] indicates the ability to open a query form, or pick a value from a list or Validation Table. Query forms use the query functions found in the query pull-down menu or the query icons on the toolbar. *(See Figures 8 & 9)*
3.1 **Search Terms**

- **Query** – to search for specific information, data or objects
- **Criteria** – the specific information provided to the system to perform the search. Query forms usually have multiple fields that can be used in a search. *For example, you can search for a specific class section on SSASECQ using one or more of the following fields; term, campus, subject, course and/ or session*
- **Match** – the search criteria are compared against the system’s records and only those records that match are returned to the query form or search field
- **Case Sensitive** – data is entered into Banner in a specific way. A query form that is case sensitive will only match those records that have the same capitalization as the criteria. *For example, on a case sensitive form a last name search for Mcdonald will not match the records spelled McDonald*. Always assume the query form is case sensitive unless a ‘Case Sensitive Query’ option field is present
- **Validation Tables** – a validation table is a list of valid codes for a given field usually accessed by pressing the Search icon
- **Wildcard** – a special character used in a query to replaced one or more other characters
  - % (percent sign) represents any number of missing characters
  - _ (underscore) represents one or more occurrence of a missing character

<table>
<thead>
<tr>
<th>To get these results…</th>
<th>Enter these criteria…</th>
</tr>
</thead>
<tbody>
<tr>
<td>All entries that contain ma</td>
<td>%ma%</td>
</tr>
<tr>
<td>All entries that begin with ma</td>
<td>ma%</td>
</tr>
<tr>
<td>All entries that end with ma</td>
<td>%ma</td>
</tr>
<tr>
<td>All entries that have m as a second character</td>
<td>_m%</td>
</tr>
</tbody>
</table>

3.2 **Person Searches**

All forms with an ID field in the key block will have a search icon. Clicking the search icon will open either a specific person search form or a menu box with type-specific search options. A methodical name search should be conducted prior to concluding that a person does not exist in the Banner system.

3.2.1 **Person Search Form (SOAIDEN)**

**Query Form** *(not case sensitive by default)*

The Person Search Form is accessed from most forms that require an ID number in the key block. The fields are ID, Last Name, First Name, Middle Name, Birth Date, Change Indicator, and Type. A search can use all or any combinations of the fields except Birth Date. The Change Indicator field identifies a change was made to the record and the type of change. The two indicators are ‘I’ for an ID change and ‘N’ for a name change.
There is variability of the data entered in the Middle Name field so it is advised to use this field only as a reference.

Enter the criteria for the search; usually Last and First Name. Use wildcards to expand the search especially if the spelling of a name can vary. (See Figure 10) Once the criteria are entered, click Query → Execute or press F8 on the keyboard.

![Figure 10 - SOAIDEN Initial Search Criteria](image)

If the person is not in the list or the system did not find a match, try again using new criteria, perhaps utilizing wildcards.

- To perform another search when records were returned, click Rollback or click Query → Cancel.
- To perform another search when no records were return, Tab to the appropriate field.

![Figure 11 - Query Results](image)

If a record was found and the search was started from a calling form like SPAIDEN or SGASTDN; click in the ID field, click the Select icon or File → Select. The selected ID will now be displayed in the calling form’s key block, click Block → Next to view on the form.
3.2.2 Person Search Detail Form (SOAIDNS)

Query Form (Case Sensitive)

This form may be used to further determine the correct person to be used for processing. The General Student Block will provide the general student information such as student type, degree, college, and major. The Address Block will provide the student's address information. The searchable fields are ID, Last Name, First Name, and Change Indicator. Enter criteria in the appropriate fields, pay attention to capitalization. Click Query → Execute. (See Figure 12)

From SOAIDEN, highlight the most closely matching record, click Query → Count Hits. SOAIDNS will open with the values for the last and first name fields from SOAIDEN. Click Query → Execute. (See Figure 12)

![Figure 12 - SOAIDNS](image)

Scroll through the matched records looking at the General Learner and Address Details blocks. If the General Learner block is empty, the person has not been a student here before. (See Figure 13)

![Figure 13 - Query Results](image)

If a record was found and the search was started from a calling form like SPAIDEN or SGASTDN; click in the ID field, click the Select icon or File → Select. The selected ID will now be displayed in the calling form’s key block, click Block → Next to view on the form.
3.2.3 System Identification (GUASYST)

Key Information: ID

Use this form to identify the Banner systems that contain information about an ID. Each system is also broken down into key modules, such as Recruiting or Admissions in the Student System. GUASYST is simply a quick-reference to systems where further information about an ID may be stored. (See Figure 14)

![GUASYST](image)

Figure 14 - GUASYST

3.3 Other Search Forms

There are numerous other query forms that have similar functionality but may look different than an ID search form. Fortunately, the search methods are the same including the use of the Query pull down menu and toolbar icons. (See Figures 8 & 9)

3.3.1 Schedule Section Query Form (SSASECQ)

Query Form

This form is used to view enrollment, location, and additional summary information and to find the CRN number for a class section. It can be access directly or by clicking the search icon next to the CRN field of the SSASECT form (See Section 4.4). This form displays two records at a time; if more records are matched, use the scroll bar to view. Any combination of fields can be used in the search. (See Figure 15) For example, Search criteria: Find all ADNU classes on the Knight campus for fall 2006 term

- Enter: Term = 200630 Subject = ADNU Campus = KN
- Click Query → Execute

![SSASECQ](image)

Figure 15 - SSASECQ

- Two records matched the criteria. (See Figure 16)
If a record was found and the search was started from a calling form like SSASECT; click in the CRN field, click the Select icon or File \(\rightarrow\) Select. The selected CRN will now be displayed in the calling form’s key block, click Block \(\rightarrow\) Next to view on the form.

4 Common Forms

4.1 General Person Identification Form (SPAIDEN)

Key Information: ID

Every person in Banner will have information on this form. Click on the named tab to see the other blocks or sections. (See Figure 17)
4.2 Hold Information (SOAHOLD)

Key Information: ID

The Hold Information form (SOAHOLD) is used to place and view holds. This form displays up to 6 hold records; if more exist, use the scroll bar on the left side of the screen. (See Figure 18)

- Hold Type – Shows the Hold code and a description. Each hold type limits the students’ ability to specific system functions. To view more information about each hold, click the search icon to display the validation table. To view additional information about each type, click the Search icon; use the scroll bar to see what each hold prevents.
- *Reason – explanation for why the hold was placed
- *Release Indicator – Checkmark indicates only the displayed user can release the hold
- *Amount – amount owed
- From and To - A value of 01-Jan-2099 in the ‘To’ date field indicates the Hold is still active
- Origination Code - Department which placed the hold.
* indicates optional fields

![SOAHOLD Form](image)

Figure 18 - SOAHOLD

Students have the ability to view the Hold information via their Pipeline account. (See Figure 19)

![Pipeline View](image)

Figure 19 - Pipeline View
4.3 **General Student (SGASTDN)**

Key Information: **ID and Term Code (optional)**

This form displays General Student records one at a time. The Term field is optional, however, on this form it is used to limit the number of records displayed. If the most current term is entered all records will be viewable, however; if an early term is entered, only those records that were effective for that term or earlier will be viewable.

Clicking the Student Summary search icon will open the General Student Summary (SGASTDQ) form which shows summary term records in a list format. *(See Section 4.3.1)*

There are several blocks of this form which are accessed from the Options menu or by clicking the named tab. *(See Figures 20, 21 & 22)*

---

**Figure 20 - SGASTDN Learner**

**Figure 21 - SGASTDN Curricula**

**Figure 22 - SGASTDN Field of Study**
4.3.1 General Student Summary Form (SGASTDQ)

Key Information: ID is the only field required

This form can be accessed directly or by clicking the search icon in the key block of SGASTDN. ID is a required field but term code should be left blank to view all the records.

This form displays general student records in a list view. As each record is selected in the Student Summary block, the Curricula Summary and Field of Study blocks will display the information connected to that term record. (See Figure 23)

Double-click the record to return it to SGASTDN.

![Figure 23 - SGASTDQ](image)

4.4 Schedule Form (SSASECT)

Key: Term Code and CRN (Course Reference Number)

The Schedule Form (SSASECT) displays class section information. There are other blocks including Meeting Time and Assigned Instructor; use the Options menu or Next Block. (See Figures 24 & 25)

![Figure 24 - SASSECT](image)
4.5 Registration Query Form (SFAREGQ)

Key Information: Term Code and ID

The Registration Query Form (SFAREGQ) provides an online view of a student’s schedule. The form displays all currently registered courses and related information, three records at a time. Use the vertical scroll bar to view any additional classes. (See Figure 26)
Appendix A. Banner Tips

General

- CCRI ID numbers begin with ‘9’ and are 8 digits long.
  - The ID fields are 9 characters long to fit a Social Security number. Press the Tab key on the keyboard to display the name when a CCRI ID is typed.
- Most functions can be executed from a pull-down list on the menu bar, pressing an icon on the toolbar, or a function key on the keyboard. (See Appendix C)
- Banner has several ways of alerting the user that an error has occurred. The most common way is by displaying the error in the Auto Hint/Status Line. The Auto Hint/Status Line is located at the bottom of the Banner screen. It is also where processing messages and keyboard shortcuts are displayed.

Forms

- In most cases, Key Block information will transfer from one form to another. Be sure that the key block is correct before clicking Next Block.
  - Be especially careful with Term fields.
- To change key block information on a form, such as the person or term, click Rollback.
- Clicking in a row makes it the active row; indicated by a color change.
- Banner keeps track of the forms opened during a session and lists them by order of use on the File pull-down menu. To reopen a form, click File → FormName

Using this method to open a form will leave the current form open.
Appendix B. Name Field Search

A person search can be started directly in the Full Name field of a key block.

1. Clear the ID field

2. Tab

3. Enter name: ‘last name, first name’ format. (Use wildcards if necessary)

4. Tab

5. If multiple records match, the ‘ID and Name Extended Search’ form will pop-up

6. Click in the ‘Search Results’ field. (Use scroll bar if needed)

7. Click on the name to return it to the calling form
   Or search further - click the ‘Person Search Detail’ icon (See Section 3.2.1)
## Appendix C. Banner 7 Navigation

### Banner Navigation

<table>
<thead>
<tr>
<th>Function</th>
<th>Menu Bar Pull-Down</th>
<th>Keystroke Option</th>
<th>Toolbar Icons</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General Functions</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save or Commit</td>
<td>File ➔ Save</td>
<td>F10</td>
<td></td>
</tr>
<tr>
<td>Rollback</td>
<td>File ➔ Rollback</td>
<td>Shift + F7</td>
<td></td>
</tr>
<tr>
<td>Select</td>
<td>File ➔ Select</td>
<td>Shift + F3</td>
<td></td>
</tr>
<tr>
<td><strong>Record Functions</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Insert Record</td>
<td>Record ➔ Insert</td>
<td>F6</td>
<td></td>
</tr>
<tr>
<td>Remove Record</td>
<td>Record ➔ Remove</td>
<td>Shift + F6</td>
<td></td>
</tr>
<tr>
<td>Previous Record</td>
<td>Record ➔ Previous</td>
<td>Up Arrow</td>
<td></td>
</tr>
<tr>
<td>Next Record</td>
<td>Record ➔ Next</td>
<td>Down Arrow</td>
<td></td>
</tr>
<tr>
<td><strong>Block Functions</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Next Block</td>
<td>Block ➔ Next</td>
<td>Ctrl + Page Down</td>
<td></td>
</tr>
<tr>
<td>Previous Block</td>
<td>Block ➔ Previous</td>
<td>Ctrl + Page Up</td>
<td></td>
</tr>
<tr>
<td><strong>Query Functions</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enter Query</td>
<td>Query ➔ Enter</td>
<td>F7</td>
<td></td>
</tr>
<tr>
<td>Execute Query</td>
<td>Query ➔ Execute</td>
<td>F8</td>
<td></td>
</tr>
<tr>
<td>Cancel Query</td>
<td>Query ➔ Cancel</td>
<td>Ctrl + Q</td>
<td></td>
</tr>
<tr>
<td><strong>General Functions</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Online Help</td>
<td>Help ➔ Online Help</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td>File ➔ Exit</td>
<td>Ctrl + Q</td>
<td></td>
</tr>
</tbody>
</table>
Appendix D. Common Errors

FRM-92101: There was a failure in the Forms Server during startup. This could happen due to invalid configuration. Please look into the web-server log file for details. (Banner will not respond after receiving this error. Close the Banner window, click on the initiation page, and click the refresh button. Banner window launches again.)

**Cause:** The date wasn’t entered in the proper format. (dd-mon-yyyy) i.e. 08-aug-2006, 23-sep-2005

**Solution:** Use the calendar pop-up to select the date or use the correct date format.

FRM-40350: Query caused no records to be retrieved

**Cause:** No records matched the criteria entered

**Solution:** Review the criteria that were entered. Is the spelling correct? Was the proper capitalization used? Is the term code correct? Etc.

FRM-40208: Form running in query-only mode. Cannot change database fields.

**Cause:** You do not have access to update or add information on this form

**Solution:** If your supervisor needs you to update or add data on this form, fill out a Banner Student Authorization form as a change, have it signed, and sent to the appropriate business area contact person listed on the form.

*Error* User blank is not authorized to access blank2

**Cause:** You tried to open a form you do not have access to open.

**Solution:** If your supervisor needs you to access this form, fill out a Banner Student Authorization form as a change, have it signed, and sent to the appropriate business area contact person listed on the form.

*Error* Blank is invalid. LIST for valid choices.

**Cause:** No form exists with that name.

**Solution:** Check for a misspelling. Unsure of the exact spelling? Try using a wildcard character.
Appendix E. Installing Oracle JInitiator

Banner Login and JInitiator Install

Step 1

Open Internet Explorer.

Navigate to Banner Project page.
http://it.ccri.edu/Banner/

Click Banner Login button.

Step 2

‘Internet Explorer – Security Warning’ dialogue box appears.

Click Install.

Step 3

‘Software Installation’ dialogue box appears.

Click Continue Anyway.
Step 4

‘Oracle JInitiator Setup’ dialogue box appears.

The Destination Folder indicates where the JInitiator will be installed.

Click **Next**.

---

---

Step 5

‘Installation Complete’ dialogue box appears.

Click **OK**.

**If an error message is displayed; remove all versions of Oracle JInitiator (see Appendix F) and try the installation again.**

---

---

Step 6

The Banner logon box should appear.
Appendix F. Uninstalling Older JInitiator

If you receive the following error after trying to install the Banner 7 JInitiator please follow the steps below to uninstall all previous versions.

"Error while registering the Oracle JInitiator 1.3.1.18 registry keys"

<table>
<thead>
<tr>
<th>Step 1</th>
<th>Close all Internet Explorer windows. In the lower left-hand corner of the computer desktop, Click the Start button.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Step 2</th>
<th>Click Control Panel.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Step 3</th>
<th>Click Add or Remove Programs. Different icon depending on the view of your Control Panel.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Step 4</th>
<th>Scroll down the alphabetically list of programs looking for versions of Oracle JInitiator. There may be more than one. Select Oracle JInitiator 1.x.x.xxxx Click Change/Remove.</th>
</tr>
</thead>
</table>


Step 5

‘Confirm File Deletion’ dialogue box appears.
Click Yes.

Step 8

‘Remove Shared File?’ dialogue box appears.
Click Yes to All.

Step 9

Another ‘Removed Shared File?’ dialogue box appears.
Click Yes.

Step 10

‘Remove Programs from Your Computer’ dialogue box appears.
Once all components have been removed,
Click OK.

Repeat steps 4 thru 10 to remove all versions of Oracle JInitiator.
Appendix G. Banner 7.x Highlights

- Plus signs on hierarchical tree menu replaced with Folder icon. You can select the product, application or form name then double-click or hit the enter key to expand/collapse the menu or open the selected form.
- Direct Access form replaced by Go To... toolbar
- Spyglass replaced by Search icon
- Open form names will display in the title bar when multiple forms are open. The [Q] symbol indicates the ability to view the information available on this form but no data entry or modification is allowed.
- Many of the forms previously available through the Option menu have been replaced with tabs.
- Date field now have a calendar pop-up for choosing the date
- Right-clicking in a form sometimes will bring up some basic Banner tools and any forms available on the Options menu.
- Online Help - Displays help information in a new browser window. Content determined by form opened when Help is accessed. (See Figure 29)
  - Help pull-down from Menu bar (See Figure 30)
  - Online Help toolbar icon (See Figure 31)
  - Help Center link on General Menu (See Figure 32)